Outage

Incident Report for Smarter Launch

Postmortem

This incident was caused due to mishandling of a 3rd party integration. Service limits were exhausted which caused the server to stop responding to requests. The appropriate measures were taken and services were restored. The 3rd party integration has been limited for the time being as further precautions are implemented to ensure better handling and stability. We appreciate your patience while we resolved the matter.

Posted Jun 12, 2025 - 11:36 MDT

Resolved

This incident was caused due to mishandling of a 3rd party integration. Service limits were exhausted which caused the server to stop responding to requests. The appropriate measures were taken and services were restored. The 3rd party integration has been limited for the time being as further precautions are implemented to ensure better handling and stability. We appreciate your patience while we resolved the matter.
Posted Jun 11, 2025 - 08:12 MDT

Update

We have resolved the issue and are continuing to monitor.
Posted Jun 11, 2025 - 08:05 MDT

Investigating

We are currently investigating this issue.
Posted Jun 11, 2025 - 07:35 MDT
This incident affected: API (API).