Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 13, 2026 - 22:00 MDT
Scheduled
Additional drawing tool enhancements including automatic building footprint drawing, improved measurement scale, additional drawing settings to toggle snapping, show/hide grid, enhanced grab handles to assist with line alignment. Improvements to photo quality for cover header photos, company logo, etc. Improved styling for scheduling preferences, and proposal acceptance. Scheduling preferences display time of day preference based on business hours. 28 other enhancements, bug fixes, etc.
Posted Mar 13, 2026 - 07:03 MDT
This scheduled maintenance affected: Web Client (Web Client) and API (API).